package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[^\W_]+[^\s\da-z.)(]?[^\W_]*$`)
var str = `abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}