re = /("""|''')[\s\S]*?\1/m
str = '\'\'\' comment comment \'\'\'
""" comment comment """
\'\'\' comment comment
comment comment
\'\'\'
""" comment comment
comment comment
"""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end