re = /{([^{}:]+)(?::([^{}]+))?}/m
str = 'hello {foo} and {bar}
hello {foo:bar} and {hello:world}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end