$re = '/(?<=-)[^-\n]+(?=-[^-\n]*$)/m';
$str = 'T-shirt Layla gaga-papa-lk
Gh world papa -mama-p';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);