$re = '/("[\s\w]*)"([\s\w]*")/';
$str = '\'{"name": "Jack O"Sullivan", "id": "1"}\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);