import re
regex = re.compile(r"(?:For:\s)?(?:For:.+)?((?<first_ip>\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}))\,", flags=re.MULTILINE)
test_str = ("For: ${jnd:ldap://${namingDetails}.for.net.sh}, 4.5.3.2, 23.200.06.110 V-\n"
"For: 10.10.21.17, 5.18.11.74, 23.36.3.22 V-\n"
"For: 23.3.39.1, 21.61.39.21 V-\n"
"For: 3.3.39.1 V-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")