$re = '/[A-Z]{0,3}\d+/m';
$str = 'AAA1234 0000123 AA12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);