import Foundation
let pattern = #"^[sS]ee, e\.g\.,(?![^()\n]*+(\(1st Cir\. \d{4}\))?[^()\n]*+(\(2nd Cir\. \d{4}\))?[^()\n]*+(\(3rd Cir\. \d{4}\))?[^()\n]*+(\(4th Cir\. \d{4}\))?[^()\n]*+(\(5th Cir\. \d{4}\))?[^()\n]*+(\(D\.C\. Cir\. \d{4}\))?\.?$).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (3rd Cir. 2017).
See, e.g., Jefferson v. U.S. (2nd Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017).
See, e.g., Lincoln v. Jones (3rd Cir. 2012); U.S. v. Roosevelt (5th Cir. 2017).
See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017).
See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017).
See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017).
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)