$re = '/^([a-z0-9_]+\.[a-z0-9_]+)+$/';
$str = 'com.my.app';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);