# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{5}\) \d{7}|\(\d{5}\) \d{4}-\d|\(\d{3}\) \d{4} \d{2} \d{4}"
test_str = ("06442) 3933023 \n"
"(02852) 5996-0 \n"
"(042) 1818 87 9919 \n"
"06442 / 3893023 \n"
"06442 / 38 93 02 3 \n"
"06442/3839023\n"
"042/ 88 17 890 0 \n"
"+49 221 549144 – 79 \n"
"+49 221 - 542194 79 \n"
"+49 (221) - 542944 79\n"
"0 52 22 - 9 50 93 10 \n"
"+49(0)121-79536 - 77 \n"
"+49(0)2221-39938-113 \n"
"+49 (0) 1739 906-44 \n"
"+49 (173) 1799 806-44\n"
"0173173990644\n"
"0214154914479\n"
"02141 54 91 44 79\n"
"01517953677\n"
"+491517953677\n"
"015777953677\n"
"02162 - 54 91 44 79\n"
"(02162) 54 91 44 79\n\n"
"2017-03-07 13:48:39 Dear Sear Madam...\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.