import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "to\\\"\\s*:\\s*\\\"(?<to>[^\\\"]+)\\\"";
final String string = "(\"data\": [\"from\" :\n"
+ "\"2024-04-25T11: 30Z\",\n"
+ "\"to\": \"2024-04-2512:00Z\",\n"
+ "\"intensity\": (\"forecast\": 152,\n"
+ "\"actual\": null, \"index\": \"moderate\"}), (\"from\": \"2024-04-25T12:002\",\n"
+ "\"intensity\": {\"forecast\": 152, \"actual\": null, \"index\": \"moderate\"}), (\"from\": \"2024-04-25T12:30Z\",\n"
+ "\"to\":\n"
+ "{\"from\": \"2024-04-25T13:00Z\", \"to\":\n"
+ "\"2024-04-25T12: 30Z\",\n"
+ "(\"forecast\": 164,\n"
+ "\"actual\": null,\n"
+ "\"2024-04-2513: 30Z\", \"intensity\": (\"forecast\": 154,\n"
+ "\"to\": \"2024-04-25T13: 002\",\n"
+ "\"intensity\": (\"forecast\": 154,\n"
+ "\"actual\": null,\n"
+ "\"index\":\n"
+ "\"actual\": null, \"index\": \"moderate\"}), (\"from\": \"2024-04-25T13:30Z*, \"to\": \"2024-04-25T14:002\",\n"
+ "\"moderate\"}},\n"
+ "\"intensity\":\n"
+ "04-25T14: 30Z\",\n"
+ "\"to\" :\n"
+ "\"index\": \"moderate\"3}, (\"from\": \"2024-04-25T14:002*, \"to\": \"2024-04-25T14:30Z\", \"intensity\": (\"forecast\": 166, \"actual\": null, \"index\": \"moderate\"}), (\"from\":\n"
+ "\" 2024-04-25T15:00Z\"\n"
+ "\"actual\": nu11,\n"
+ "\"index\"\n"
+ "\"intensity\": {\"forecast\": 170, \"actual\": null, \"index\": \"moderate\"}), {\"from\": \"2024-04-2515: 00Z\",\n"
+ "2024-\n"
+ "\"to\" :\n"
+ "\"moderate\"}), {\"from\": \"2024-04-25T15:30Z\", \"to\": \"2024-04-25T16:00Z\", \"intensity\": (\"forecast\": 175,\n"
+ "\"to\": \"2024-04-25T15: 30Z\",\n"
+ "\"intensity\": {\"forecast\": 172,\n"
+ "\"2024-04-25T16: 30Z\",\n"
+ "\"index\": \"moderate\"}}, (\"from\": \"2024-04-25T17:00Z\", \"to\":\n"
+ "\"intensity\": (\"forecast\": 177, \"actual\": null, \"index\": \"moderate\"?), (\"from\": \"2024-04-2516: 302\",\n"
+ "\"actual\" : nu11,\n"
+ "\"index\"\n"
+ "\"moderate\"}}, (\"from\": \"2024-04-2516: 00Z\",\n"
+ "\"to\": \"2024-04-25T17:002\",\n"
+ "\"intensity\": (\"forecast\": 179,\n"
+ "\"actual\": null,\n"
+ "2024-04-2517: 30Z\", \"intensity\": (\"forecast\": 181, \"actual\": null,\n"
+ "25T18:00Z\", \"intensity\": (\"forecast\": 184,\n"
+ "\"index\": \"moderate\"}}, {\"from\": \"2024-04-25T17: 30Z\",\n"
+ "\"actual\": null, \"index\": \"moderate\"}), (\"from\": \"2024-04-25T18:002\", \"to\": \"2024-04-25T18: 30Z\",\n"
+ "\"to\": \"2024-04-\n"
+ "\"moderate\"}}, (\"from\": \"2024-04-2518: 30Z\", \"to\": \"2024-04-25T19:002\",\n"
+ "\"intensity\": (\"forecast\": 187, \"actual\": null,\n"
+ "\"intensity\": (\"forecast\": 190,\n"
+ "\"actua1\": nul1,\n"
+ "\"index\":\n"
+ "\"index\":\n"
+ "\"high\"}}, (\"from\":\n"
+ "\"intensity\": {\"forecast\": 193,\n"
+ "\"actual\": null, \"index\":\n"
+ "\"2024-04-25T19: 00Z\", \"to\":\n"
+ "\"2024-04-25T19: 30Z\"\n"
+ "\"high\"}}, (\"from\": \"2024-04-25T19:30Z\", \"to\": \"2024-04-25T20:00Z\", \"intensity\":\n"
+ "{\"forecast\": 194,\n"
+ "\"2024-04-2520: 00Z\", \"to\": \"2024-04-25T20:30Z\", \"intensity\": {\"forecast\": 195, \"actual\": null, \"index\": \"high\"3}, (\"from\": \"2024-04-25T20:30Z\",\n"
+ "\"actual\": null, \"index\": \"high\")}, (\"from\":\n"
+ "\"2024-04-25T21:00Z\", \"intensity\": (\"forecast\":\n"
+ "198, \"actual\": null, \"index\": \"high\"'), (\"from\": \"2024-04-25T21: 002\",\n"
+ "\"2024-04-25T22: 00Z\", \"intensity\": {\"forecast\": 187, \"actual\": null,\n"
+ "\"to\": \"2024-04-25T21: 30Z\", \"intensity\": {\"forecast\": 196,\n"
+ "'actual\": null,\n"
+ "\"index\": \"high\"}}, {\"from\": \"2024-04-25T21:302\"\n"
+ "\"to\"\n"
+ "\"index\": \"moderate\"}}, (\"from\": \"2024-04-25T22:00Z\", \"to\":\n"
+ "\"2024-04-25T22: 30Z\",\n"
+ "\"intensity\": (\"forecast\": 181, \"actual\": null,\n"
+ "\"index\": \"moderate\"}}, {\"from\": \"2024-04-25T22:30Z\", \"to\": \"2024-04-25T23:002\", \"intensity\": (\"forecast\": 180, \"actual\": null,\n"
+ "\"index'\n"
+ "moderate\"}},{\"from\":\n"
+ "25T23:30Z\", \"intensity\": {\"forecast\": 172, \"actual\": null, \"index\": \"moderate\"}}, {\"from\": \"2024-04-25T23: 30Z\",\n"
+ "\"2024-04-25T23:002\",\n"
+ "\"to\":\n"
+ "\" 2024-04-\n"
+ "\"moderate\"}}, {\"from\": \"2024-04-26T00:00Z\", \"to\": \"2024-04-2600: 30Z\", \"intensity\": (\"forecast\": 150,\n"
+ "\"to\": \"2024-04-2600: 00Z\",\n"
+ "\"intensity\": (\"forecast\": 150,\n"
+ "\"actual\": null,\n"
+ "\"index\":\n"
+ "\"actual\": null, \"index\": \"moderate\")}, (\"from\": \"2024-04-26T00: 302\",\n"
+ "\"to\": \"2024-04-26T01:00Z\"\n"
+ "\"intensity\": {\"forecast\": 149,\n"
+ "\"actual\": null,\n"
+ "\"index\": \"moderate\"}}, (\"from\": \"2024-04-26T01:002\",\n"
+ "\"to\": \"2024-04-26T01:30Z\", \"intensity\": {\"forecast\": 149,\n"
+ "\"actual\": null,\n"
+ "\"index\":\n"
+ "\"moderate\"}}, ...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}