$re = '/^[0-9]+$/m';
$str = '12454853
123g123
12
9012
123er';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);