$re = '/^(?!.{256})(?:[\p{L}]+(?:\.[\p{L}]+)*@(?:(?:[\p{L}](?:(?:\p{L}|[^\P{S}<>])*[\p{L}])?\.)+[\p{L}](?:(?:\p{L}|[^\P{S}<>])*[\p{L}])?|\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\]))$/m';
$str = 'a@te<>st.com
a@[127.0.0.1]
a@test.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);