re = /(?:\G(?!\A)|\/)[^e\n]*\Ke/m
str = '/zombie nimble zombie quick
Plants vs Zombies reference
lorem ipsum /some e characters here as well'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end