#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<nameID aor=\"sip:)(?:\+)?(.*)(@.*)\s(.*)(<name>)(")(.*)(")(<\/name>).*\R(.*)\R(.*)\R(.*)\R(.*)\R(.*)(<apkt:callingParty>false<\/apkt:callingParty>)"
Local $sString = "<nameID aor="sip:+13136622147@sip.quickenloans.com">" & @CRLF & _
" <name>"User 3136622147"</name>" & @CRLF & _
" </nameID>" & @CRLF & _
" <send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>" & @CRLF & _
" <associate-time>2021-04-20T13:57:07</associate-time>" & @CRLF & _
" <extensiondata xmlns:apkt="http://acmepacket.com/siprec/extensiondata">" & @CRLF & _
" <apkt:callingParty>false</apkt:callingParty>" & @CRLF & _
"" & @CRLF & _
"<nameID aor="sip:3136622147@sip.quickenloans.com">" & @CRLF & _
" <name>"User 3136622147"</name>" & @CRLF & _
" </nameID>" & @CRLF & _
" <send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>" & @CRLF & _
" <associate-time>2021-04-20T13:57:07</associate-time>" & @CRLF & _
" <extensiondata xmlns:apkt="http://acmepacket.com/siprec/extensiondata">" & @CRLF & _
" <apkt:callingParty>false</apkt:callingParty>" & @CRLF & _
"" & @CRLF & _
"<nameID aor="sip:136622147@sip.quickenloans.com">" & @CRLF & _
" <name>"User 3136622147"</name>" & @CRLF & _
" </nameID>" & @CRLF & _
" <send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>" & @CRLF & _
" <associate-time>2021-04-20T13:57:07</associate-time>" & @CRLF & _
" <extensiondata xmlns:apkt="http://acmepacket.com/siprec/extensiondata">" & @CRLF & _
" <apkt:callingParty>false</apkt:callingParty>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")