using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<!(?:[\s\S]*\{[\s\S]*){2,})(?<=""version"" *: *"")([\d\.]*)(?="")|(?<=""version"" *: *"")([\d\.]*)(?="")(?!(?:[\s\S]*\}[\s\S]*){2,}))";
string input = @"{ ""dependencies"": { ""version"": ""1.0.0"" }, ""version"": ""1.0.0"" }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}