# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(?P<key>[ABCD])\.\s+.+
(?=
(?:\n[ABCD]\.\s+.+){0,3}
\n
\nKey:\s+(?!(?P=key))
)
"""
test_str = ("Question: What is the capital city of France?\n"
"A. Berlin\n"
"B. Paris\n"
"C. Rome\n"
"D. Madrid\n\n"
"Key: B\n\n"
"Question: Who is credited with inventing the World Wide Web?\n"
"A. Steve Jobs\n"
"B. Bill Gates\n"
"C. Tim Berners-Lee\n"
"D. Mark Zuckerberg\n\n"
"Key: C")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.