re = /^(?:http|https):\/\/www.pitchup.com\/(?P<lang>[^\/]+\/)?campsites\/(?:(?!-\/)[^\/]+\/){5}\??.*$/m
str = 'https://www.pitchup.com/campsites/England/South_West/Cornwall/Helston/chy-carne-camping-and-touring-park/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end