$re = '/<(a|h[1-6])[^>]*>(?:[a-zA-Z0-9\s\'\-\.,]|(?:<(.*)>.*<\/\1>))*<\/(a|h[1-6])>(*SKIP)(*FAIL)|\b(Find Me)\b(?=[^>]*(?:<|$))/i';
$str = 'Lorem ipsum find me and skip when
<b>find me</b> is inside a link tag
like this find me
<h1>find me in the title</h1>
<a href="#">here you can find me too</a>.
<h2 class="heading">Lorem Ipsum dolor find me here too</h2>
<table>
<tr><td>Cell 1 a</td><td>Find me</td></tr>
<tr><td>Cell 2 with find me</td><td><a href="#foo">Find me</a></td></tr>
</table>
<h3 class="heading">Duomo Di find me San Martino</h3>
<p>FIND ME as well</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);