# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"RIASWIX.*?Sky Access"
test_str = ("----Document Start-------\n\n"
"Paragraph*\n\n"
"RIASWIX.* ABCDEF1 NONE\n"
" WORKING: HELLO(READ)\n"
" BOOLEAN Access: SADGRE3, VJFKES3, JGJKEWW, IS4DWF44(A), DFEAWE2(G),\n"
" DW4444W, IHFK3MF3\n"
" BAZAAR Access: No resource with BAZAAR Access\n"
" GHAR Access: No resource with GHAR Access\n"
" WATER Access: ADMINDDD(A), GEDDE33\n"
" SKY None: No Resource with Sky Access\n\n"
"RIASWIX.@7483NFJ.* HFDFDF3 NONE\n"
" WORKING: BYE(READ)\n"
" BOOLEAN Access: GRREGGG, GREFEFF, GFGGGG, FDFDFDF(A), RERERE3(G),\n"
" GFFWEF44, FFRF44F\n"
" BAZAAR Access: No resource with BAZAAR Access\n"
" GHAR Access: No resource with GHAR Access\n"
" WATER Access: ADMINEWW(A), FFRFRGR\n"
" SKY None: No Resource with Sky Access\n\n"
"RIASWIX.@7483KXX.* HFDFDF3 NONE\n"
" WORKING: TATA(READ)\n"
" BOOLEAN Access: GRDSD33, FASDE, GFGGGG, RWERW33(A), NMUYHT4(G),\n"
" BAZAAR Access: XCDFEFE3, FREFE33R\n"
" GHAR Access: No resource with GHAR Access\n"
" WATER Access: DASDEFG(A), SJMFEIOE(P)\n"
" SKY None: No Resource with Sky Access\n\n"
"*Text\n\n"
"----Document End-------")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.