#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s+"
Local $sString = "aaaaa" & @CRLF & _
"aaa aaa" & @CRLF & _
"aaa aaa" & @CRLF & _
" aaa " & @CRLF & _
" a a a a a "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")