import Foundation
let pattern = #"\b(34[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b34[0-9]{13}\b|\b(37[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b37[0-9]{13}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
American Express
Requirements: American Express cards start with the number 34 or 37 and have 15 digits. Pattern is 4-6-5 when having spaces or dashes.
Pattern Parts:
Starts with number 34 and 15 length:
1) \b(34[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b34[0-9]{13}\b
Starts with number 37 and 15 length:
2) \b(37[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b37[0-9]{13}\b
Combining 1-2 to form one pattern:
\b(34[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b34[0-9]{13}\b|\b(37[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b37[0-9]{13}\b
Test Cases:
Positive (Should fire):
15 length, no space, start with 34 342312341234112
15 length, dashes, start with 34 3423-123456-12345
15 length, spaces, start with 34 3423 123456 12345
15 length, no space, start with 37 372112341234123
15 length, dashes, start with 37 3721-123456-12345
15 length, spaces, start with 37 3721 123456 12345
Embedded in sentence with space:
15 length, no space, start with 34 Here is the cc: 342312341234112
15 length, dashes, start with 34 Here is the cc: 3423-123456-12345
15 length, spaces, start with 34 Here is the cc: 3423 123456 12345
15 length, no space, start with 37 Here is the cc: 372112341234123
15 length, dashes, start with 37 Here is the cc: 3721-123456-12345
15 length, spaces, start with 37 Here is the cc: 3721 123456 12345
15 length, no space, start with 34 Credit Card#:342312341234112
15 length, dashes, start with 34 Credit Card#:3423-123456-12345
15 length, spaces, start with 34 Credit Card#:3423 123456 12345
15 length, no space, start with 37 Credit Card#:372112341234123
15 length, dashes, start with 37 Credit Card#:3721-123456-12345
15 length, spaces, start with 37 Credit Card#:3721 123456 12345
Negative (Should Not Fire):
15 length, no space, not start with 34 352312341234112
15 length, dashes, not start with 34 3523-123456-12345
15 length, spaces, not start with 34 3523 123456 12345
15 length, no space, not start with 37 362112341234123
15 length, dashes, not start with 37 3621-123456-12345
15 length, spaces, not start with 37 3621 123456 12345
15 length, no space, start with 34, embedded Credit Card Number342312341234112
15 length, dashes, start with 34, malformed 3423-1234-1234-112
15 length num matching pattern but embedded User ID: 000000342312341234112000000
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)