package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(a*b)a{3}`)
var str = `aabaaabaaabaaaaaab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}