#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^^(?![^?\n]*\?)(?!.*(interpersonal\.meta\.stackexchange\.com)).*good\s+answer"
Local $sString = "Here are the strings I want to detect:" & @CRLF & _
"--------------------------------------" & @CRLF & _
"That a very good answer!" & @CRLF & _
"(Other than that, this is a really good answer and I've upvoted it.)" & @CRLF & _
"good answer dvdf!" & @CRLF & _
"dsds good answer cfds" & @CRLF & _
"It is a good answer, but I feel it played into the OP's hands really. You said what they wanted to hear - that they shouldn't freely share the information because it is like a child cheating on their homework. It is contrary to the spirit of this site, and I'm not sure that charging a colleague money to learn something work-based from you won't get the OP into trouble with their employer. Imagine if a doctor asked to confer with a fellow doctor in order to help a patient, and they charged each other for the information they shared. They'd be dismissed." & @CRLF & _
"" & @CRLF & _
"Here are the one I don't want to detect" & @CRLF & _
"-----------------------------------------" & @CRLF & _
"Thanks for this good answer! (I upvoted it) However, I still don't understand why I shouldn't mention that I believe whatever? What's the problem with that..." & @CRLF & _
"cxvd good answer? zedfs" & @CRLF & _
"ezdds? good answer dsf dsf" & @CRLF & _
"sdsd? dsfdsf? good answer!" & @CRLF & _
"Hi, the question is "How to tell blabla when X is my good friend", would you mind be a little more detail about how OP should do that when OP still want to be friend with both parties? Also, please take some time to read "How do I write a good answer" & @CRLF & _
"As a side note, here is a link to "How do I write a good answer?" & @CRLF & _
"Hi, this sound like a good answer to me, I just have one question though: Where you in a similar situation before where you successfully used this technic? In here it's better to back-up your answer with personal experience (here is a guide to How to write a good answer if you need it)" & @CRLF & _
"" & @CRLF & _
"New formule" & @CRLF & _
"--------------" & @CRLF & _
"Hey, welcome to IPS! At the time being, your answer doesn't seem to actually address the question and is likely to get deleted. However, you can still edit it after reading "<a href="https://interpersonal.meta.stackexchange.com/q/3266/21067">How to write a good answer</a>" to try to make the answer up to your standards." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"On a side note, here is a link to "[How to write a good answer](https://interpersonal.meta.stackexchange.com/q/3266/21067)" and here is one to the [help center](https://interpersonal.stackexchange.com/help/how-to-answer)." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")