$re = '@^/offers/([0-9a-zA-Z_:.-]+)/test$@m';
$str = '/offers/xyz:req:test0030-10-title:co/test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);