use strict;
my $str = 'aaa bbb ccc
aaa bbb key1:aaa ccc ddd
aaa bbb key2:aaa key1:bbb
aaa bbb key1 ccc
aaa bbb key1:xxx key2:
aaa bbb key1: xxx ccc
aaa bbb key1 :xxx ccc
aaa bbb aakey1
aaa bbb key1aa
aaa bbb xxx:yyy zzz';
my $regex = qr/\b(?:key1|key2)\b:?(?:\h+|$)|\b(?!(?:key1|key2)\b)[^\s:]+:/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}