re = /(<p>){1}(\s)*(<br>|<br\/>){0,9}(\s)*(<\/p>){1}(\s)*$/m
str = '</span><p></p><p></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end