$re = '`(?:https?://)?(?:www\.)?facebook\.com/\S+`m';
$str = 'facebook.com/xxxxx
www.facebook.com/xxxxx
http://facebook.com/xxxxx
https://facebook.com/xxxxx
facebook.com/ ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);