re = /^(?:(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])(\.(?!$)|$|,|-)){3,4}(\*|(?:(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])(\.(?!$)|$|,)){4})?$/m
str = '255,255,255,255-0,0,0,0
255.255.255.255
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end