#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}"
Local $sString = "Valid" & @CRLF & _
"e519f23b-1c3e-5320-8ed0-4c17b8177c05" & @CRLF & _
"" & @CRLF & _
"Invalid" & @CRLF & _
"e519z23b-1c3e-5320-8ed0-4c17b8177c05" & @CRLF & _
"" & @CRLF & _
"Invalid" & @CRLF & _
"e519-323b-1c3e-5320-8ed0-4c17b8177c0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")