import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<bucket>[^\\/]+)\\/(?:(?P<prefix>.+)\\/)?AWSLogs\\/(?P<aws_account_id>[\\d]{12})\\/elasticloadbalancing\\/(?P<region>[\\w\\d\\-]+)\\/(?P<year>\\d{4})\\/(?P<month>\\d{2})\\/(?P<day>\\d{2})\\/(?P=aws_account_id)_elasticloadbalancing_(?P=region)_(?P<load_balancer_id>[\\w\\.\\-\\d]+)_(?P<end_time>\\d{8}T\\d{4}Z)_(?P<ip_address>(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))_(?P<random_string>.+)\\.log\\.gz$";
final String string = "log-bucket/AWSLogs/113901497002/elasticloadbalancing/us-east-1/2020/04/26/113901497002_elasticloadbalancing_us-east-1_app.us-east-lt-alb.5ac1c221b7cf2245_20200426T0225Z_34.233.232.149_nhinzchd.log.gz\n"
+ "log-bucket/web-lt/AWSLogs/113901497002/elasticloadbalancing/us-east-1/2020/04/26/113901497002_elasticloadbalancing_us-east-1_app.us-east-lt-alb.5ac1c221b7cf2245_20200426T0225Z_34.233.232.149_nhinzchd.log.gz\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}