# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b\d(?!(?:\d{0,3}([-\/\\.])\d{1,2}\1\d{1,4})\b(?!\S))(?:[^\n\d]*\d){14}\b"
test_str = ("data: 19-04-052-320-008-55,19 04 052 320 008 75,19/04/052/320/0/0/8/8/0, 190405232000895 \n\n"
	"a 21-10-070-006-164-00 2014-03-31 1650000 0.84 7560\n"
	"b 21 100 700 061 65 00 2014-3-31 1650000 0.84 7560\n"
	"c 21.1.0.0.7.000616300 2014-04-1 5050000 1.34 16979\n"
	"d 2 1.1/0 0a70b00c616300 2014-04-10 5050000 1.34 16979\n"
	"e 21 1x00x 7xx00x0500100 14-04-2016 6800000 2.03 20307\n"
	"f 211007002506100 4-06-2022 4005000 2.21 14949\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.