$re = '/(^|\s+)(?:foo|\d+)(?=\s+|$)/m';
$str = 'Foo World 4563
Hello World 435 Foo';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;