using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(<[^>]*class=(""|')(\w|\ |\-)*))((?<= |\'|\"")(foo-|-foo)[^ ""']*)";
string input = @"<body>
<div style=""margin-left:6px;"" class=""foo-pink blfoo-pin-foo-kue red yellow bar-green -moz-FF foo-pink moz-FF foo-pink"" >
<fieldset class=""foo customClass foo clFieldsBar bar-try"" id=""idField foo- bar-dfgdgdfg"">
<legend><span>Qu'en pensez-vous ?</span></legend>
< id=""idText"" class='foo- Comment_text fdgdgdfg -foo-ddede mso-whitespace' name=""nameText barName""></textarea> bar-deded foo-green
</fieldset>
class=""blue dffsf sdf mso-green foo""
</div>
</body>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}