use strict;
my $str = 'яблоко|апельсин|груша|вишня';
my $regex = qr/[^|]*\|/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";