$re = '/^.*(?<=(H|h)ome).*world.*(\.|!)$/m';
$str = '> Home is now behind you, the world is ahead!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);