using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Invoice ((?:[0-9]){8})";
string input = @"THIS IS AN EXAMPLES OF Invoice Email Subject sample
Harmonie Mutuelle - Invoice 1234567890123456
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}