$re = '/\d{1,}(?:\,?\d{3})*(?!千伏|千吨)(?:千)/m';
$str = '220千伏
220千吨
220千';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);