re = /(?<time>[^ ]* [^-]*) - +(?<name>[^-]*) - (?<message>[^ ]*.*$)/m
str = '2021/01/14 16:57:33 - Copy rows to result.0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end