const regex = /[A-Z](\w|')*\.?\s+([A-Z](\w|')*\.\s+|(\w|')*\s+|"[^"]*"\s+)*([A-Z](\w|')*\.|(\w|')*|"[^"]*")(\.|[?!])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z](\\w|\')*\\.?\\s+([A-Z](\\w|\')*\\.\\s+|(\\w|\')*\\s+|"[^"]*"\\s+)*([A-Z](\\w|\')*\\.|(\\w|\')*|"[^"]*")(\\.|[?!])', 'g')
const str = `'Dr. T.G. Walker alarmed the whole 20.50 train when Mr. T.G. Walker got up shouting at 10 o'clock.' "The exchange rate was at 500.72." After the crowd dissipated the police also went home. 'Mr. Sherlock Holmes and Dr. John Watson and Mrs. Williams together with T.G. Hooker and Capt. Marshall, of course, were better than the F.B.I. at crime fighting. Feb. 20 Mr. Barack Obama vowed as a candidate before Rep. TestNameAbbreviation that he would put the U.S. on a path to addressing climate change A.S.A.P!!!!!!!
Is that so? Unfortunately, yes. That is so. Truly? Is that true? Yes, it is true. Well, then! Yes that is so, A.S.A.P! Help us please! This is from I.T? Yes, it is. No, it is not.
Y. Yea.
Is that so, truly? Yes, that is so. Unfortunately it is.....
Is that really the case, Anthony? Why yes, yes it is. Is that really the case? Really, is it, so?
On Saturday, Sgt. Timothy said...
Sgt. Timothy said ...
It was I! For they are dead.
Trailing punctuation test!!!!!! Test?!. Test?!. Test!? Test?! Test...test....
Harry, you're a 'wizard'. Yes, really. (this only splits because of |\\S{4,})
New line one, which without ending punctuation, is not detected
I would use |(?:[^\\r\\n]+) but this seems to break the regex
New line three
New line four, etc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}