re = /\b(c\+\+)[\s.,!?]/m
str = 'this is a c++ test
this is a c++. test
this is a c+++ test
this is a c++- test
this is a c++! test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end