using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?i)wänt|wäns|prägs|prägt|quäls|quält|Rätsel|Rätsele|Rätselen|souveränst|souveränste|souveränstem|souveränsten|souveränster|souveränt|trägst|trägste|trägstem|trägsten|trägster|trägt|zäms|zämt)((\S*?ä|፼))([b-df-hj-np-tv-z][b-df-hj-np-tv-z]\S*)";
string input = @"Match: prägs
Don’t match: aprägs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}