re = /^(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d$@$!%*?&#]{6,}$/m
str = 'pa1234
pa#123
pa#\\123
pa1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end