re = /^\[?(?:(?:(?:0000:){5}|::)ffff:)?([\w:.]*)/m
str = '2600::1
2001:db8:0:0:1:0:0:1
2001:db8:85a3::8a2e:370:7334
[2001:db8:85a3::8a2e:370:7334]
5cc:1d47:39bf:3b52:593d:633e:f045:3ec4
5cc:1d47:39bf:3b52::1
192.168.1.1
0.0.0.0
255.255.255.255
[0000:0000:0000:0000:0000:ffff:255.255.255.255]
::ffff:255.255.255.255
fe80::593d:633e:f045:3ec4
fe80:0000:0000:0000:593d:633e:f045:3ec4
::1
0:0:0:0:0:0:0:1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end