$re = '/((101)(01|)*)|((010)(10|)*)/m';
$str = '5 cadenas que cumplen
010
101
1010101
01010
10101010101
5 cadenas que no cumplen
01
0101
01101
1001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);