# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@\S+//gm;t' <<< "asdf@gmail.com
rick.rick@rick.com
sdfgewreg-sdfg@owpdbp.co.uk"