re = /^(?:https?:\/\/)?(?:www\.)?([^\s\:\/\?\[\]\@\!\$\&\'\(\)\*\+\,\;\=\<\>\#\%\"\{\}\|\\\^\`]{1,63}\.(?:com|org|net|int|edu|gov|mil|arpa|ac|ad|ae|af|ag|ai|al|am|an|ao|aq|ar|as|at|au|aw|ax|az|ba|bb|bd|be|bf|bg|bh|bi|bj|bl|bm|bn|bo|bq|br|bs|bt|bv|bw|by|bz|ca|cc|cd|cf|cg|ch|ci|ck|cl|cm|cn|co|cr|cu|cv|cw|cx|cy|cz|de|dj|dk|dm|do|dz|ec|ee|eg|eh|er|es|et|eu|fi|fj|fk|fm|fo|fr|ga|gb|gd|ge|gf|gg|gh|gi|gl|gm|gn|gp|gq|gr|gs|gt|gu|gw|gy|hk|hm|hn|hr|ht|hu|id|ie|il|im|in|io|iq|ir|is|it|je|jm|jo|jp|ke|kg|kh|ki|km|kn|kp|kr|kw|ky|kz|la|lb|lc|li|lk|lr|ls|lt|lu|lv|ly|ma|mc|md|me|mf|mg|mh|mk|ml|mm|mn|mo|mp|mq|mr|ms|mt|mu|mv|mw|mx|my|mz|na|nc|ne|nf|ng|ni|nl|no|np|nr|nu|nz|om|pa|pe|pf|pg|ph|pk|pl|pm|pn|pr|ps|pt|pw|py|qa|re|ro|rs|ru|rw|sa|sb|sc|sd|se|sg|sh|si|sj|sk|sl|sm|sn|so|sr|ss|st|su|sv|sx|sy|sz|tc|td|tf|tg|th|tj|tk|tl|tm|tn|to|tp|tr|tt|tv|tw|tz|ua|ug|uk|um|us|uy|uz|va|vc|ve|vg|vi|vn|vu|wf|ws|ye|yt|za|zm|zw|الجزائر|xn--lgbbat1ad8j|հայ|xn--y9a3aq|বাংলা|xn--54b7fta0cc|бел|xn--90ais|бг|xn--90ae|中国|xn--fiqs8s|中國|xn--fiqz9s|مصر|xn--wgbh1c|ею|xn--e1a4c|გე|xn--node|ελ|xn--qxam|香港|xn--j6w193g|भारत|xn--h2brj9c|بھارت|xn--mgbbh1a71e|భారత్|xn--fpcrj9c3d|ભારત|xn--gecrj9c|ਭਾਰਤ|xn--s9brj9c|இந்தியா|xn--xkc2dl3a5ee0h|ভারত|xn--45brj9c|ಭಾರತ|xn--2scrj9c|ഭാരതം|xn--rvc1e0am3e|ভাৰত|xn--45br5cyl|ଭାରତ|xn--3hcrj9c|بارت|xn--mgbbh1a|भारतम्|xn--h2breg3eve|भारोत|xn--h2brj9c8c|ڀارت|xn--mgbgu82a|ایران|xn--mgba3a4f16a|عراق|xn--mgbtx2b|الاردن|xn--mgbayh7gpa|қаз|xn--80ao21a|澳门|xn--mix082f|澳門|xn--mix891f|мкд|xn--d1alf|مليسيا|xn--mgbx4cd0ab|мон|xn--l1acc|المغرب|xn--mgbc0a9azcg|عمان|xn--mgb9awbf|پاکستان|xn--mgbai9azgqp6j|فلسطين|xn--ygbi2ammx|قطر|xn--wgbl6a|рф|xn--p1ai|السعودية|xn--mgberp4a5d4ar|срб|xn--90a3ac|新加坡|xn--yfro4i67o|சிங்கப்பூர்|xn--clchc0ea0b2g2a9gcd|한국|xn--3e0b707e|ලංකා|xn--fzc2c9e2c|இலங்கை|xn--xkc2al3hye2a|سودان|xn--mgbpl2fh|سورية|xn--ogbpf8fl|台湾|xn--kprw13d|台灣|xn--kpry57d|ไทย|xn--o3cw4h|تونس|xn--pgbs0dh|укр|xn--j1amh|امارات|xn--mgbaam7a8h|اليمن|xn--mgb2ddes|abc|academy|accountant|accountants|active|actor|ads|adult|aero|agency|airforce|analytics|apartments|app|archi|army|art|associates|attorney|auction|audible|audio|author|auto|autos|aws|baby|bananarepublic|band|bank|bar|barefoot|bargains|baseball|basketball|beauty|beer|best|bestbuy|bet|bible|bid|bike|bingo|bio|biz|black|blackfriday|blockbuster|blog|blue|boo|book|boots|bot|boutique|box|broadway|broker|build|builders|business|buy|buzz|cab|cafe|call|cam|camera|camp|cancerresearch|capital|car|cards|care|career|careers|cars|case|cash|casino|catering|catholic|center|ceo|cfd|channel|chat|cheap|christmas|church|cipriani|circle|city|claims|cleaning|click|clinic|clothing|cloud|club|coach|codes|coffee|college|community|company|compare|computer|condos|construction|consulting|contact|contractors|cooking|cool|coop|country|coupon|coupons|courses|credit|creditcard|cruise|cricket|cruises|dad|dance|data|date|dating|day|deal|deals|degree|delivery|democrat|dental|dentist|design|dev|diamonds|diet|digital|direct|directory|discount|diy|docs|doctor|dog|domains|dot|download|drive|duck|earth|eat|eco|education|email|energy|engineer|engineering|enterprises|equipment|esq|estate|events|exchange|expert|exposed|express|fail|faith|family|fan|fans|farm|fashion|fast|feedback|film|final|finance|financial|fire|fish|fishing|fit|fitness|flights|florist|flowers|fly|foo|food|foodnetwork|football|forsale|forum|foundation|free|frontdoor|fun|fund|furniture|fyi|gallery|game|games|garden|gift|gifts|gives|glass|global|gold|golf|gop|graphics|green|gripe|grocery|group|guide|guitars|guru|hair|hangout|health|healthcare|help|here|hiphop|hiv|hockey|holdings|holiday|homegoods|homes|homesense|horse|hospital|host|hosting|hot|hotels|house|how|ice|industries|info|ing|ink|institute|insurance|insure|international|investments|jewelry|jobs|joy|kim|kitchen|land|latino|law|lawyer|lease|legal|lgbt|life|lifeinsurance|lighting|like|limited|limo|link|live|living|loan|loans|locker|lol|lotto|love|luxury|makeup|management|map|market|marketing|markets|mba|med|media|meet|meme|memorial|men|menu|mint|mobi|mobile|mobily|moe|mom|money|mortgage|motorcycles|mov|movie|museum|name|navy|network|new|news|ngo|ninja|now|observer|off|one|ong|onl|online|ooo|open|organic|origins|page|partners|parts|party|pay|pet|pharmacy|phone|photo|photography|photos|physio|pics|pictures|pid|pin|pink|pizza|place|plumbing|plus|poker|porn|post|press|prime|pro|productions|prof|promo|properties|property|protection|pub|qpon|racing|radio|read|realestate|realtor|realty|recipes|red|rehab|reit|ren|rent|rentals|repair|report|republican|rest|restaurant|review|reviews|rich|rip|rocks|rodeo|room|rugby|run|safe|sale|save|scholarships|school|science|search|secure|security|select|services|sex|sexy|shoes|shop|shopping|show|showtime|silk|singles|site|ski|skin|sky|sling|smile|soccer|social|software|solar|solutions|song|space|spot|spreadbetting|storage|store|stream|studio|study|style|sucks|supplies|supply|support|surf|surgery|systems|talk|tattoo|tax|taxi|team|tech|technology|tel|tennis|theater|theatre|tickets|tips|tires|today|tools|top|tours|town|toys|trade|trading|training|travel|travelersinsurance|trust|tube|tunes|uconnect|university|vacations|ventures|vet|video|villas|vip|vision|vodka|vote|voting|voyage|wang|watch|watches|weather|webcam|website|wed|wedding|whoswho|wiki|win|wine|winners|work|works|world|wow|wtf|xxx|xyz|yachts|yoga|you|zero|zone|shouji|tushu|wanggou|weibo|xihuan|arte|clinique|luxe|maison|moi|rsvp|sarl|epost|gmbh|haus|immobilien|jetzt|kaufen|kinder|reise|reisen|schule|versicherung|desi|shiksha|casa|immo|moda|voto|bom|passagens|abogado|gratis|futbol|hoteles|juegos|ltda|soy|tienda|uno|viajes|vuelos|在线|xn--3ds443g|中文网|xn--fiq228c5hs|移动|xn--6frz82g|网址|xn--ses554g|网络|xn--io0a7i|公司|xn--55qx5d|商城|xn--czru2d|机构|xn--nqv7f|我爱你|xn--6qq986b3xl|商标|xn--czr694b|世界|xn--rhqv96g|集团|xn--3bst00m|дети|xn--d1acj3b|католик|ком|xn--j1aef|онлайн|xn--80asehdb|орг|xn--c1avg|сайт|xn--80aswg|संगठन|xn--i1b6b1a6a2e|कॉम|नेट|닷컴|닷넷|קום|xn--9dbq2a|みんな|xn--q9jyb4c|セール|ファッション|ストア|ポイント|クラウド|コム|คอม|africa|capetown|durban|joburg|abudhabi|arab|asia|doha|dubai|krd|kyoto|nagoya|okinawa|osaka|ryukyu|taipei|tatar|tokyo|yokohama|alsace|amsterdam|bcn|barcelona|bayern|berlin|brussels|budapest|bzh|cat|cologne|corsica|cymru|eus|frl|gal|gent|hamburg|helsinki|irish|ist|istanbul|koeln|london|madrid|moscow|nrw|paris|ruhr|saarland|scot|stockholm|swiss|tirol|vlaanderen|wales|wien|zuerich|boston|miami|nyc|quebec|vegas|kiwi|melbourne|sydney|lat|rio|佛山|xn--1qqw23a|广东|москва|xn--80adxhks|рус|ابوظبي|عرب|aaa|aarp|abarth|abb|abbott|abbvie|accenture|aco|aeg|aetna|afl|agakhan|aig|aigo|airbus|airtel|akdn|alfaromeo|alibaba|alipay|allfinanz|allstate|ally|alstom|americanexpress|amex|amica|android|anz|aol|apple|aquarelle|aramco|audi|auspost|axa|azure|baidu|barclaycard|barclays|bauhaus|bbc|bbt|bbva|bcg|bentley|bharti|bing|blanco|bloomberg|bms|bmw|bnl|bnpparibas|boehringer|bond|booking|bosch|bostik|bradesco|bridgestone|brother|bugatti|cal|calvinklein|canon|capitalone|caravan|cartier|cba|cbn|cbre|cbs|cern|cfa|chanel|chase|chintai|chrome|chrysler|cisco|citadel|citi|citic|clubmed|comcast|commbank|creditunion|crown|crs|cuisinella|dabur|datsun|dealer|dell|deloitte|delta|dhl|discover|dish|dnp|dodge|dunlop|dupont|dvag|edeka|emerck|epson|ericsson|erni|esurance|etisalat|eurovision|everbank|extraspace|fage|fairwinds|farmers|FedEx|ferrari|ferrero|fiat|fidelity|firestone|firmdale|flickr|flir|flsmidth|ford|fox|fresenius|forex|frogans|frontier|fujitsu|fujixerox|gallo|gallup|gap|gbiz|gea|genting|giving|gle|globo|gmail|gmo|gmx|godaddy|goldpoint|goodyear|google|grainger|guardian|gucci|hbo|hdfc|hdfcbank|hermes|hisamitsu|hitachi|hkt|honda|honeywell|hotmail|hsbc|htc|hughes|hyatt|hyundai|ibm|ieee|ifm|ikano|imdb|infiniti|intel|intuit|ipiranga|iselect|itau|itv|iveco|jaguar|java|jcb|jcp|jeep|jpmorgan|juniper|kddi|kerryhotels|kerrylogistics|kerryproperties|kfh|kia|kindle|komatsu|kpmg|kred|kuokgroup|lacaixa|ladbrokes|lamborghini|lancaster|lancia|lancome|landrover|lanxess|lasalle|latrobe|lds|lego|liaison|lexus|lidl|lifestyle|lilly|lincoln|linde|lipsy|lixil|locus|lotte|lpl|lplfinancial|lundbeck|lupin|macys|maif|man|mango|marriott|maserati|mattel|mcd|mcdonalds|mckinsey|meo|metlife|microsoft|mini|mit|mitsubishi|mlb|mma|monash|mormon|moto|movistar|msd|mtn|mtpc|mtr|mutual|mutuelle|nadex|nationwide|natura|nba|nec|netflix|neustar|newholland|nexus|nfl|nhk|nico|nike|nikon|nissan|nissay|nokia|northwesternmutual|norton|nra|ntt|obi|office|omega|oracle|orange|orientexpress|otsuka|ovh|pamperedchef|panasonic|pccw|pfizer|philips|piaget|pictet|ping|pioneer|play|playstation|pohl|politie|praxi|prod|progressive|pru|prudential|pwc|quest|qvc|redstone|reliance|rexroth|ricoh|rmit|rocher|rogers|rwe|safety|sakura|samsung|sandvik|sandvikcoromant|sanofi|sap|saxo|sbi|sbs|sca|scb|schaeffler|schmidt|schwarz|scjohnson|scor|seat|sener|ses|sew|seven|sfr|seek|shangrila|sharp|shaw|shell|shriram|sina|skype|smart|sncf|softbank|sohu|Sony|spiegel|stada|staples|star|starhub|statebank|statefarm|statoil|stc|stcgroup|suzuki|swatch|swiftcover|symantec|taobao|target|tatamotors|tdk|telecity|telefonica|temasek|teva|tiffany|tjx|toray|toshiba|total|toyota|travelchannel|travelers|tui|tvs|ubs|unicom|uol|ups|vanguard|verisign|vig|viking|virgin|visa|vista|vistaprint|vivo|volkswagen|volvo|walmart|walter|weatherchannel|weber|weir|williamhill|windows|wme|wolterskluwer|woodside|wtc|xbox|xerox|xfinity|xperia|yahoo|yamaxun|yandex|yodobashi|youtube|zappos|zara|zip|zippo|ارامكو|اتصالات|联通|中信|xn--fiq64b|香格里拉|淡马锡|大众汽车|vermögensberater|xn--vermgensberater-ctb|vermögensberatung|xn--vermgensberatung-pwb|グーグル|xn--qcka1pmc|谷歌|xn--flw351e|工行|嘉里|嘉里大酒店|飞利浦|诺基亚|電訊盈科|香格里拉|淡马锡|大众汽车|삼성|xn--cg4bki|example|invalid|local|localhost|onion|test|إختبار|xn--kgbechtv|آزمایشی|xn--hgbk6aj7f53bba|测试|xn--0zwm56d|測試|xn--g6w251d|испытание|xn--80akhbyknj4f|परीक्षा|xn--11b5bs3a9aj6g|δοκιμή|xn--jxalpdlp|테스트|xn--9t4b11yi5a|טעסט|xn--deba0ad|テスト|xn--zckzah|பரிட்சை|xn--hlcj6aya9esc7a))(?:\/|:|\?|\&|\s|$)\/?/im
str = '// Warning! Incorrectly Does not match
--Still looking
// Warning! Incorrectly Matches
--Still looking
// Correctly Does not match
http://example.coom // unregistered TLDs
http://example.comonnowthisaintatld // unregistered TLDs
http://中国.中中国 // unregistered Non-Punycoded TLDs
中国. // Unended TLDs
example .com //embedded space(s)
htt://example.com //incorrect protocol
example.com //leading space(s)
http://www.example.com //leading space(s)
http://ex[mple.com // Unwise Characters {}|\\^[]` (See RFC-1738 for URLs http://www.ietf.org/rfc/rfc1738.txt and RFC-2396 for URIs http://www.ietf.org/rfc/rfc2396.txt as well as the newer RFC-3986 http://www.ietf.org/rfc/rfc3986.txt)
http://ex?ample.com // Reserved Characters ;/?:@&=+$
http://www.example#.com // Delims <>#%"
// Correctly Extracts only domain with subdomain and without protocol and port
example.com/page1/
example.at/page1/
example.red/page1/
subdomain.example.online/page1/
subdomain2.subdomain1.example.com/
example.red:80
example.xn--pgbs0dh/page1/
x.com/there-will-never-be-pages/on-this-specific-domain/1.html
// Correctly Matches Domains With No Trailing Slash
example.com
example.at
example.red
example.online
example.xn--pgbs0dh
x.com
http://example.com
http://example.at
http://example.red
http://example.online
http://example.xn--pgbs0dh
https://example.com
https://example.at
https://example.red
https://example.online
https://example.xn--pgbs0dh
http://www.example.com
http://www.example.at
http://www.example.red
http://www.example.online
http://www.example.xn--pgbs0dh
https://www.example.com
https://www.example.at
https://www.example.red
https://www.example.online
https://www.example.xn--pgbs0dh
// Correctly Matches Trailing Slash
example.com/
example.at/
example.red/
example.online/
example.xn--pgbs0dh/
x.com/
http://example.com/
http://example.at/
http://example.red/
http://example.online/
http://example.xn--pgbs0dh/
https://example.com/
https://example.at/
https://example.red/
https://example.online/
https://example.xn--pgbs0dh/
http://www.example.com/
http://www.example.at/
http://www.example.red/
http://www.example.online/
http://www.example.xn--pgbs0dh/
https://www.example.com/
https://www.example.at/
https://www.example.red/
https://www.example.online/
https://www.example.xn--pgbs0dh/
// Correctly Extract only domain with subdomain without protocol
example.com/page1/
example.at/page1/
example.red/page1/
example.online/page1/
example.xn--pgbs0dh/page1/
x.com/there-will-never-be-pages/on-this-specific-domain/1.html
http://example.com/page2.html
http://example.at/page2.html
http://example.red/page2.html
http://example.online/page2.html
http://example.xn--pgbs0dh/page2.html
https://example.com/page3/image1.jpg
https://example.at/page3/image1.jpg
https://example.red/page3/image1.jpg
https://example.online/page3/image1.jpg
https://example.xn--pgbs0dh/page3/image1.jpg
http://www.example.com/page4/script1.php?i=4928&d=oloklo5o
http://www.example.at/page5/subpage1/script.php?i=4928&d=oloklo5o
http://www.example.red/page-number-6/sub-page-number2
http://www.example.online/page_7/script-2.php?complex_attr=%20-_-%20,1209&simple_attr=22&something_else=ooooooooop
http://www.example.xn--pgbs0dh/page_8/script-3.php?uri_in_attr=http://www.example.com/page9&simple_attr=53331
// Correctly Matches Case Insensitive
https://www.Example.com/
https://www.Example.At/
https://www.EXAPLE.RED/
https://subdomain.example.online/
// Correctly matches Non Punycoded domain names and registered TLDs including RTL TLDs
中国.com
såfa.com
https://citröen.de
http://中国.中国/
http://中国.中国
https://www.example.تونس/ //LTR example TLD
example.中國
http://example.ελ/page12/
https://www.ex.香港
www.ex.भारत
https://الجزائر.تونس/ // Full RTL domain/subdomain + RTL TLD (matches - regex101 doesnt seem to highlight correctly though)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end