re = /((\[\d+:\d+\])\s+(.*)\s+-\s+(.*))/m
str = 'Text text text
Tracklist:
[00:00] Sobs - Girl
[02:25] Mopac - Cross-Eyed Dreaming
[05:54] L I P S - In Summer
[09:18] Small Wood House - T.V
Text text text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end