$re = '/(.*\/)[^\/]*/';
$str = '/wave=1/sin2=1/sin1=2/sin0=3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);