# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"filename=\"Myfile\.pdf\"\s*(\S.*(?:\n\S.*)*)"
test_str = ("--------------A5B0A8B4F69F8BD959B758D0\n"
"Content-Type: application/pdf;\n"
" name=\"Myfile.pdf\"\n"
"Content-Transfer-Encoding: base64\n"
"Content-Disposition: attachment;\n\n"
"filename=\"Myfile.pdf\"\n\n"
"JVBERi0xLjQKJeLjz9MKMyAwIG9iago8PC9UeXBlL1hPYmplY3QvQ29sb3JT\n"
"ZWI0ODRmNDE1ZDE0YmIyZmU2YjAzZDMzNjU+PGU5MDFiZTMzY2FlOTY4ZDM2\n"
"NmFmOGNhOTUxNTE0Nzk0Pl0vSW5mbyAyMyAwIFIvU2l6ZSAyND4+CnN0YXJ0\n"
"eHJlZgoyMzg2NgolJUVPRgo=\n\n"
"--------------A5B0A8B4F69F8BD959B758D0--\n"
"--------------A5B0A8B4F69F8BD959B758D0\n"
"Content-Type: application/pdf;\n"
" name=\"Myfile.pdf\"\n"
"Content-Transfer-Encoding: base64\n"
"Content-Disposition: attachment;\n"
" filename=\"Myfile.pdf\"\n\n"
"JVBERi0xLjQKJeLjz9MKMyAwIG9iago8PC9UeXBlL1hPYmplY3QvQ29sb3JT\n"
"ZWI0ODRmNDE1ZDE0YmIyZmU2YjAzZDMzNjU+PGU5MDFiZTMzY2FlOTY4ZDM2\n"
"NmFmOGNhOTUxNTE0Nzk0Pl0vSW5mbyAyMyAwIFIvU2l6ZSAyND4+CnN0YXJ0\n"
"eHJlZgoyMzg2NgolJUVPRgo=\n\n"
"--------------A5B0A8B4F69F8BD959B758D0--")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.